+38 (044) 362-68-16  +38 (068) 968-31-40
04080, Украина, г. Киев
ул. Викентия Хвойки, 21
корп. 1, эт.1, оф. 2-3   

Интеграция кассового аппарата МИНИ Т-400 с 1С 7.7 и 1С 8.2

Получить консультацию по компоненте Вы можете по телефону +380 (93) 747-20-99 или напишите запрос на почту info@abavas.com.ua или

в ЧАТ


Последняя версия компоненты (1.1.43) от 13.08.2013

 

Скачать комплект разработчика (компонента, примеры интеграции компоненты с 1С 7.7 и 1С 8.2, справочные материалы).

 

Изменения в версии 1.1.43 от 13.08.13

 

Исправлена ошибка записи отладочной информации при работе с 1С:Предприятием 8.2

 

Изменения в версии  1.1.42 от 08.08.13

 

Добавлен режим сохранения ответа в режиме отладки от сервера при отправке прайса.

Ответы сохраняются в двух файлах: "request.xml" - текст отсылаемого запроса и 

"result.xml" - ответ от сервера (только при работе с локальным шлюзом в режиме 0 и 2, 

ответ от Reteko не передается)

 

Изменения в версии 1.1.41 от 06.08.2013

 

Исправлена ошибка поиска ключа при работе с 1С:Предприятием 8.2

 

Изменения в версии 1.1.40 от 05.08.2013 

 

Добавлена возможность работать с Z-отчетами из реестра.

 

Информация об отчетах доступна после выполнения метода ПолучитьЧеки.

 

Добавлен метод:

ПолучитьZОтчет(GetZRead)

 

В качестве параметра передается порядковый номер в пределах от 1 до КоличествоZОтчетов  

Метод возвращает строку с датой и временем Z-отчета в формате ГГГГММДДЧЧММСС или "-1" в случае ошибки.

Например: 20130717111900 - 17 июля 2013 года 11 часов 19 минут 00 секкнд

 

Добавлены новые свойства:

КоличествоZОтчетов (ZreadsAmount) - возвращает количество отчетов в заданном интервале (интервал задается в методе "ПолучитьЧеки")

 

ZОтчетПолученоНал - Сумма полученных денег в копейках (наличная форма оплаты)

ZОтчетПолученоБезНал - Сумма полученных денег в копейках (все безналичные формы оплаты*)

ZОтчетВозвратБезНал - Сума выданных денег в копейках (наличная форма оплаты)

ZОтчетВозвратНал - Сума выданных денег в копейках (все безналичные формы оплаты*)

ZОтчетКвоЧековПродаж - Количество чеков продажи

ZОтчетКвоЧековВозвратов - Количество чеков возвратов

НомерЧека - фискальный номер Z-отчета (если аппарат работает в нефискальном режиме, НомерЧека всегда будет равен 0). В таком случае в качестве номера отчета можно использовать штамп времени, которые возвращает метод ПолучитьZОтчет.

 

Внимание! Вышеуказанные свойства становятся актуальными после выполнения метода ПолучитьZОтчет.

* В кассовом аппарате МИНИ Т-400 есть возможность запрограммировать 8 типов оплаты (3 - фиксированных (наличные, чек, картой (кредит)) и 5  - программируемых пользователем (например, можно запрограммировать под расчеты по предоплаченным картам, подарочным сертификатам и т.д.). Более подробно см. в руководстве пользователя кассового аппарата команды 620, 623, 625, 626. В данной версии компоненты все 7 типов безналичной оплаты возвращаются общей суммой. Планируется расширение методов для идентификации каждого вида безналичного платежа.

 

 

Изменения в версии 1.1.39.

 

- добавлено свойство Версия, которое возвращает версию загруженной компоненты

- в методы ПолучитьЧеки и ОтправитьПрайс добавлена возможность работать с локальным шлюзом напрмяую без подключения к интернету. Для работы в таком режиме необходимо запросить у разработчиков файл лицензии.

- методы ПолучитьЧеки и ПолучитьСтроку возвращают -1 в случае ошибки. Оисание ошибки содержится в свойстве ОписаниеОшибки.

 

1.Быстрый старт для 1с 8.2

-для веб шлюза Reteko

Создаем прайс:

ЗагрузитьВнешнююКомпоненту(ПутьККомпоненте+"UNS.dll");

UNS = Новый ("Addin.UNS");

ДействуетС = Формат(НаДату, "ДФ=ггггММдд")+"000000";

UNS.СоздатьПрайс(ДействуетС,номерККМ ,флагОчисткиПрайса);    

Для каждоготовара из списка Цикл

UNS.ДобавитьТовар(Наименование,Артикул,ЦенаВКопейках,Кво,НалоговаяГруппа,ШтрихКод,Весовой,КонтрольОстатка);

КонецЦикла;

UNS.ОтправитьПрайс(НомерККМ, ФайлПодписи.pem,1);

 

Где

номерККМ = заводской номер кассы (только цифры). Например: 4101101444

флагОчисткиПрайса = 1 или 0. Очищать ли прайс в кассовом аппарате при загрузке нового

ФайлПодписи.pem = сертификат подписи. Предоставляется компанией Юнисистем.

 

Загружаем  чеки:

ЗагрузитьВнешнююКомпоненту(ПутьККомпоненте+"UNS.dll");

            UNS = Новый ("Addin.UNS");          

            ДатаС = Формат(НачальнаяДата, "ДФ=гггг-ММ-дд");     

            ДатаПо= Формат(КонечнаяДата, "ДФ=гггг-ММ-дд");       

            КвоЧеков = UNS.ПолучитьЧеки(ДатаС,ДатаПо,НомерКассы,ФайлПодписи,"1");

            Для а=1 по Число(КвоЧеков) Цикл

                        UNS.ПолучитьЧек(а);

                        Для счСтрок=1 По UNS.КоличествоСтрок Цикл

                                   UNS.ПолучитьСтроку(счСтрок);    

                                   Сообщить("НалоговаяГруппа = "+СокрЛП(UNS.НалоговаяГруппа));

                                   Сообщить("Сумма = "+СокрЛП(UNS.Сумма));

                                   Сообщить("Количества ="+СокрЛП(UNS.Количество));

                                   Сообщить("Цена ="+СокрЛП(UNS.Цена));

                                   Сообщить("Код ="+СокрЛП(UNS.Код));

                                   Сообщить("Штрихкод ="+СокрЛП(UNS.ШтрихКод));

                                   Сообщить("Название ="+СокрЛП(UNS.Название));

                                   Сообщить("Отменен ="+СокрЛП(UNS.Отменен));

                        КонецЦикла;

            КонецЦикла;

 

-для локального шлюза

Процедуры аналогичны как для веб шлюза. Разница только в строчке при отправке прайса

UNS.ОтправитьПрайс(НомерККМ, ИнтернетАдресЛокальногоШлюза,0);

 

и при получении чеков

КвоЧеков = UNS.ПолучитьЧеки(ДатаС,ДатаПо,НомерКассы, ИнтернетАдресЛокальногоШлюза, "0");

 

 

Подобный подход в использовании позволяет в кратчайшие сроки интегрировать кассовые аппараты серии МИНИ-Т400 в существующую систему учета на базе 1С 8.2 и 7.7.

 

Специалистами нашей компании разработаны готовые к использованию обработки для типовых конфигурации, которые не требует вмешательства в программный код продукта.

Обработки свободны для распространения и исходный код из них вы можете использовать в своих решениях.

 

Методы компоненты

 СоздатьПрайс(ДействуетС,номерККМ ,флагОчисткиПрайса);    

            Начало создания прайса.   

 ДобавитьТовар(Наименование,Артикул,ЦенаВКопейках,Кво,НалоговаяГруппа,ШтрихКод,Весовой,КонтрольОстатка)

             Добавить товар в ранее открытый прайс

 ОтправитьПрайс(НомерККМ, Параметр,ВидШлюза)

            Отправить ранее созданный и сформированный прайс на шлюз.

            ВидШлюза может принимать значение:

                       0 – используется локальный шлюз

1 – используется шлюз Reteko

2 – использовать прямое подключение к локальному шлюзу

             Параметр – содержит ссылка на файл подписи, если используется шлюз Reteko, или адрес вашего локального шлюза (IP-адрес или DNS-имя без указания протокола. Например, «90.90.90.90» или «gate.avavas.com») с открытыми портами 12700 и 12702

 ПолучитьЧеки(ДатаС,ДатаПо,НомерКассы, Параметр,ВидШлюза);

            Запросить данные у шлюза о чеках за период

            ВидШлюза может принимать значение:

 

0 – используется локальный шлюз

1 – используется шлюз Reteko

2 – использовать прямое подключение к локальному шлюзу

             Параметр – содержит ссылка на файл подписи, если используется шлюз Reteko, или адрес вашего локального шлюза (IP-адрес или DNS-имя без указания протокола. Например, «90.90.90.90» или «gate.avavas.com») с открытыми портами 12700 и 12702

Метод возвращает количество зарегистрированных на шлюзе чеков.

 В случае ошибки возвращает значение -1. В свойстве ОписаниеОшибки содержится строка с описанием ошибки.

 

ПолучитьЧек(НомерЧека)

            Позиционируется на чеке. НомерЧека – порядковый номер чека в выборке.

КоличествоСтрок  - количество строк в текущем чеке.

ПолучитьСтроку(номерСтроки)

Позиционируется на строке чека. НомерСтроки – порядковый номер строки.

В случае ошибки возвращает значение -1. В свойстве ОписаниеОшибки содержится строка с описанием ошибки.

 

Свойства компоненты:

 

Версия – возвращает версию используемой компоненты.

Описание ошибки – содержит строку с описаним ошибки.

ДатаЧека – Дата закрытия чека

ВремяЧека – Время закрытия чека

НомерЧека – Порядковый номер чека в кассовом аппарате.

НалоговаяГруппа – налоговая группа товара в чеке.

Сумма – сумма товара в грн.

Количество – количество товара.

Цена – цена товара.

Код – артикул товара.

ШтрихКод – штрихкод товара (если есть)

Название – название товара.

Отменен – признак (0 или 1), что товар был далее по чеку отменен. Например, если в чеке было три операции:

            Продажа товара №1

            Продажа товара №2

            Отмена товара №2

 то компонента вернет две строки чека:

            Товар №1 со статусом отменен = 0

            Товар №2 со статусом отменен = 1

 

Данное свойство позволяет в прикладном решении проводить анализ отмен.


Интеграция 1С с МИНИ Т-400

 

Напишите Ваш вопрос в ЧАТ

Roshen.pngЗавод-Кобзаренко.pngВенБест.pngVIPHalls.pngPako-Lorente.pngZabugorie.pngПечерская-международная-школа.pngНаш крайDomina.pngAnex-Tour.png
Логотип компании "Абавас"
 +38(044)362-68-16  +38(068)968-31-40


abavas.com.ua 10 из 10 на основе 8 оценок. 10 пользовательских отзывов.